【1】下载

失中方官网下载http://www.bootcss.com/

设若您是开网页练习,你可以动用CDN加速服务,免去下载等痛苦,当然你用的当儿要产生连接上网络。中方的官网也提供了诸多品类之CDN加速服务,我这里就是直接贴上官网自己之CDN加速服务吧。

<!-- 新 Bootstrap 核心 CSS 文件 -->
<link rel="stylesheet" href="http://cdn.bootcss.com/bootstrap/3.2.0/css/bootstrap.min.css">

<!-- 可选的Bootstrap主题文件(一般不用引入) -->
<link rel="stylesheet" href="http://cdn.bootcss.com/bootstrap/3.2.0/css/bootstrap-theme.min.css">

<!-- jQuery文件。务必在bootstrap.min.js 之前引入 -->
<script src="http://cdn.bootcss.com/jquery/1.11.1/jquery.min.js"></script>

<!-- 最新的 Bootstrap 核心 JavaScript 文件 -->
<script src="http://cdn.bootcss.com/bootstrap/3.2.0/js/bootstrap.min.js"></script>

由Bootstrap提供了预编译版本及源码版本,但是这里我们唯有下充斥预编译Bootstrap版本即可,对于想只要深刻摸底的得友善生充斥源码版本,在后头如读书的历程中我们为是盖预编译版本为主,除非有异说明。

【2】目录结构(说明以CDN加速服务被有涉嫌)

图片 1

每当此处结构中我们发现2只问题

1、css文件以及js文件之中还发出提供min版本,也就是说bootstrap.css文件减少后给bootstrap.min.css,其他的都是一致的,使用的时节看你们的村办喜欢,当然我引进用min版。

2、不是说Bootstrap所有 JavaScript 插件都负
jQuery的也,怎么这个组织中尚无呀?

于这个题材我们如果以官网文档中扣下虽知晓了

Bootstrap依赖jQuery

请注意,有着 JavaScript 插件都指
jQuery,因此jQuery必须于Bootstrap之前引入

就像在 基础模版遭所出示的一致。在bower.json文件 中列有了Bootstrap所支持之jQuery版本。

咱点击其中的以
bower.json文件链接,就见面跳反到https://github.com/twbs/bootstrap/blob/v3.2.0/bower.json

图片 2

自从此处我们就可以看到Bootstrap-v3.2.0版用的JQuery版本要超过1.9.0版本,至于下载JQuery,自己百度或是谷歌吧,如果您疲惫的言辞就就此自身极其上面粘出来的CDN加速服务遭遇的JQuery地址吧。

相关文章

网站地图xml地图